Xdebug and Komod IDE

3 replies [Last post]
btran
Offline
Last seen: 6 years 42 weeks ago
Joined: 2012-04-04

I could not get the Xdebug to trigger Komodo IDE per video Drupal 7
Development Core Concepts. Under section 4, video 18, How hooks are invoked
with module_invoke_all()

I have Xdebug on with the little red stop turn on in Firefox running on MAC mountain lion, on the Komodo
IDE side, I have the trails.module open with line 24 click with the red
hexagon turn on. When I refresh the page localdrupal/admin/modules in
Firefox, with conditions above, Komodo IDE does not jump out as described
between 4:13 to 4:23.

Any Help is appreciated. Really like to learn how these tools work.

Thanks.

frostmar
Offline
Last seen: 6 years 29 weeks ago
Joined: 2011-06-11
What version of Komodo?

Which version of Komodo are you using? There is a recent version (though not the most current) that has a bug in this area. I had to apply a patch!

That's the first thing I would check.

btran
Offline
Last seen: 6 years 42 weeks ago
Joined: 2012-04-04
It said version 7.1. I did

It said version 7.1. I did check for updates, but no update was available.

Not sure where to start troubleshoot.

frostmar
Offline
Last seen: 6 years 29 weeks ago
Joined: 2011-06-11
Let's dig a little deeper.

I'm using Linux so things may be in slightly different places for you.

Firstly, do you have Xdebug installed in PHP? You should have these lines in /etc/php5/apache2/php.ini

zend_extension=/path/to/xdebug.so"
xdebug.remote_enable=1
xdebug.remote_handler=dbgp
xdebug.remote_mode=req
xdebug.remote_host=127.0.0.1
xdebug.remote_port=9000
xdebug.idekey=<idekey>

You will notice that the first line has "/path/to/xdebug.so". You will need to replace this with the correct path. Do you have the correct version of xdebug.so? If not you can get this from here. Download the PHP Remote Debugging Client Max OSX Universal. This is a tarball which, when unpacked will give you various xdebug.so files. It's probably 5.3 you want but, if you run

php -v

from a shell it will confirm this.

Copy the file in question to somewhere sensible then amend the /path/to/xdebug.so to reflect where you have just put it.

You may have to restart apache - I'm not sure.

In Komodo, go to edit/preferences/debugger/connection and set the port to 9000.

In Komodo, go to edit/preferences/languages/php and you should see a nice green tick saying "successfully configured for php debugging"

Then, it should work.

Hope it works out for you.

Add to playlist

Add to , or

Add to new playlist:

Add to playlist
This is a member-only feature
But, it's easy to become a member

Add to cart:


Loading...
Contact us

Below are the supported keyboard shortcuts for our video player.

space
Start / stop video
shift
Go to next video
shift
Go to previous video
Increase or decrease player speed by 20%
Skip ahead or go back by 15 seconds
1...9
Jump to a percentage (2 is 20%, for example)
f
Toggle full screen
Videos Pricing More Search
BuildAModule Logo Icon BuildAModule Logo Icon
Become a member!
$29
1 month
$156
6 months
10% off
$276
12 months
20% off
All memberships come with the following:
24 / 7 access to the entire 1800+ video library
An innovative video player with a rolling transcript
Extensive Drupal and cross-platform training
A thorough and thoughtful training style
Progress tracking
Take notes on specific video sections
Intuitive multi-user management
How many users?
user
Go solo with a single user, or give multiple team members access through one account and get discounts by bundling multiple users into a single membership.