Remote server connect problem: Permission denied (publickey,password)

1 reply [Last post]
plus362
Offline
Last seen: 6 years 47 weeks ago
Joined: 2012-03-23

The tutorial vedios are really great as many clients have already mentioned. One of the problems is that it didn't touch much about how to deal with the remote server as many people are using internet server(such as 1and1) to host their website now. This issue might be very important. If it doesn't work, any of the rest could only draw on a beautiful paper, but not practicable. This is really frustrated to amateurs like me.

Now I'm frustrated for this issue:

I'm using 1and1 and I have confirmed that they provide ssh access and they have installed git on the server so it's ready to use. I have successfully logged into my account using ssh (it asked the password in the process). I uploaded the drush-7.x-5.1.zip and unzipped it into my account root so it creat a drush fold with everything in it (I bought linux server). I used ssh to enter the drush folder and tested drush commands (I knew it wouldn't work but wanted to see what happen). It said syntax error, unexpected '{' in environment.inc on line 518 . I checked the line in that file but it looked nonsense to me but I wanted to neglect it because you cannot just upload a software and run it there, otherwise you could do hack. But the vedio said we can do drush on our own PC to drush the remote server. This makes sense because we just run the software drush on our own PC but only modify files on the server, and we have right to do that since we paid that so that part of hard drive on the server is ours and we have right to do anything within that part, but we cannot run the software on the server even it located on the part we've paid, because the software itself might do something out of that part we've paid. So we can drush the remote files locally but not remotely.

Now there comes problem. We can drush the remote files on our local PC, but the remote server need to identify us before we are allowed to do that (it needs to know those files are belong to us). The version control vedio about modifying the aliases.drushrc.php to drush remote repository actually demo-ed locally. There's no permission issue for the remote server to identify you. But when I did it (drush @live status) lively on my remote server, it gave this message "Permission denied (publickey,password)", and there was even no step for me to input the password to get permitted. It just jumped back to new command line. So I tried to solve this problem.

First I tried to open a new terminal window and login to the server, and came back to the old terminal window and tried again, but still get the same deny.(this looks stupid to experts, but I'm amateur.)

Second I checked the aliases.drushrc.php in more detail and didn't see any place touched about the server password, but only database password. So I have no idea about how to solve it in this file.

Last I tried to find a way to do publickey. I searched internet and found somebody suggested to use dursh pushkey (http://drupal.org/node/1000784). I tried and saw the authorized_keys and PC_id_rsa.pub created on my remote server. But it still doesn't work with the same problem with the same message.

Is anybody who is successful could post the detail method to do it so I could finish this final step?

I'm also strongly suggesting that this school could pay like $3.99 to bought a shared host and demo-ed it lively on vedio. (Do not be thrift for that and you might be got waived the fee if you negociate because you will do very good to their business since a big part of students might directly use the host in your vedio to realize their projects.) All what I want to say is that I'm not only just talking about a specific problem in this post, but the school should do this part immediately and right now! It will benefit everybody in the world if you consider the causal circle.

How to realize all of these techniques on remote host is the final and indispensable part of the tutorial.

Thanks very, very much for this site! He is a hero.

gang

Chris Shattuck
Offline
Last seen: 3 weeks 3 days ago
Joined: 2009-08-16
Hi Gang, I agree that this

Hi Gang,

I agree that this would be great to cover, and I hope to before too long. It sounds like you maybe haven't set up the proper public / private key pairs. Each host has different instructions on doing this, so when asking support for help, let them know that this is one thing you want to figure out.

With the error you're getting with Drush, it also sounds like something strange is going on there.

Definitely post back if you get this working, and I'll add your requests to the video wish list. :)

Cheers!
Chris

Add to playlist

Add to , or

Add to new playlist:

Add to playlist
This is a member-only feature
But, it's easy to become a member

Add to cart:


Loading...
Contact us

Below are the supported keyboard shortcuts for our video player.

space
Start / stop video
shift
Go to next video
shift
Go to previous video
Increase or decrease player speed by 20%
Skip ahead or go back by 15 seconds
1...9
Jump to a percentage (2 is 20%, for example)
f
Toggle full screen
Videos Pricing More Search
BuildAModule Logo Icon BuildAModule Logo Icon
Become a member!
$29
1 month
$156
6 months
10% off
$276
12 months
20% off
All memberships come with the following:
24 / 7 access to the entire 1800+ video library
An innovative video player with a rolling transcript
Extensive Drupal and cross-platform training
A thorough and thoughtful training style
Progress tracking
Take notes on specific video sections
Intuitive multi-user management
How many users?
user
Go solo with a single user, or give multiple team members access through one account and get discounts by bundling multiple users into a single membership.