Module Instructions not showing README of INSTALL files in module list

7 replies [Last post]
boblucore
Offline
Last seen: 1 year 23 weeks ago
Joined: 2012-08-16

Hi Chris (and everyone),
I am working my way through the advanced site building lessons. Everything has worked well so far. But, for some reason, not the Module Instructions module. Everything looks correct. I used Drush to install and enable it. It shows up as enabled on the module listing page. But no README.txt files or INSTALL.txt links show up with the descriptions of the modules. I see the usual configure, permission and help links, but the module instructions module isn't working for some reason.

I shows and installed and enabled. I have refreshed, cleared all caches, logged out and logged back in--none of that makes a difference. I see nothing on Drupal.org referring to this problem.

My installation is local w/ Aquia dev desktop. I have Mac running Maverick. Any clues would be most appreciated.

I just tried installing it on the MagnifAscent site that I completed earlier, and it also fails to show th README or INSTALL links there. This leads me to believe it is some quirk in my Aquia installation or something walled off on my Mac.

Does anyone have a clue what could be going on? Any clues would be most appreciated.

Bob Lucore

John Q.T. Nguyen
Offline
Last seen: 5 years 24 weeks ago
Joined: 2012-06-13
That's very strange. Have

That's very strange. Have you tried completely uninstalling the module by removing the files, and then going to /admin/modules/uninstall? Sometimes, going through the uninstall process and reinstalling the module can help with strange anomalies.

When something like this occurs and the problem persists, one of the first things I usually try to do is install a different version of the same module (which, in this case, would be the dev version) to see if that works for me instead.

On a somewhat related note, I've seen some unexpected behavior come about when there are different versions of the same module within the modules directory. That's most likely not the case here, but I thought I would throw it out there!

oliverbrown72
Offline
Last seen: 5 years 20 weeks ago
Joined: 2014-01-05
Fixed - clash with Module Filter 7.x-2.0-alpha2

Hi,

I had the same issue. Uninstalled Module Instructions, installed the dev version, didn't work. Disabled the Module Filter module and it worked! I could see the links to the readme files for contributed modules.

Then realized I had installed Module Filter 7.x-2.0-alpha2 , disabled and uninstalled this, installed 7.x-1.8 and enabled it and then Module Instructions seemed to be working fine, displaying the links to readme files.

Regards,
Oliver

rockie667
Offline
Last seen: 3 years 42 weeks ago
Joined: 2014-03-22
Perfect

Thanks Oliver, works perfectly!!! :)

tomreavley
Offline
Last seen: 4 years 19 weeks ago
Joined: 2014-05-21
Thanks!

Thanks Oliver - that did the trick for me too!

abrindell7
Offline
Last seen: 4 years 11 weeks ago
Joined: 2013-12-23
'Module Instructions' Disappear When Enabling 'Module Filter'

Hi All: I've tried the suggestions here. What I'm finding is that when I enable Module Filter along with Module Instructions, then the README link disappears. However, if I leave Module Instructions enabled but DISABLE Module Filter, then I can see the README link in the Operations column.

I tried disabling/re-enabling, uninstalling/re-installing(same then different dev version). This is when I tried disabling Module Filter and blamo... I could see that Module Instructions is actually working. Just not in conjunction with Module Filter. I'm following the videos on the site here. I wonder if there is a new setting or something.

Keep in mind that while I cannot see the README, I CAN see the Configure and Permissions links that appear within the Operations column. so it's not like the Operations col isn't appearing, just the README from the Mod Instr module.

Any advice here?

Chris Shattuck
Offline
Last seen: 5 weeks 3 days ago
Joined: 2009-08-16
Hi there! I haven't tried the

Hi there!

I haven't tried the latest versions myself, but another viewer mentioned that the those links might now be placed in a drop-down button, rather than being immediately visible.

Let me know if you happen to see that going on as well.

Cheers!
Chris

mfuller526
Offline
Last seen: 2 years 19 weeks ago
Joined: 2013-03-15
Still no read me files with module filter

I disabled module_filter 7.x-2.0 and I could see the read me files in admin-menu, module filter and coffee. I uninstalled module_filter 7.x-2.0, flushed caches and installed module_filter 7.x-2.x-dev, enabled it and the read me files disappeared again. Obviously a conflict. I removed and installed module_instructions 7.x-1.x-dev. Same problem. The dev version is the latest, but dated October 2013 so it's old. I'll write a bug report for the module developers.

Add to playlist

Add to , or

Add to new playlist:

Add to playlist
This is a member-only feature
But, it's easy to become a member

Add to cart:


Loading...
Contact us

Below are the supported keyboard shortcuts for our video player.

space
Start / stop video
shift
Go to next video
shift
Go to previous video
Increase or decrease player speed by 20%
Skip ahead or go back by 15 seconds
1...9
Jump to a percentage (2 is 20%, for example)
f
Toggle full screen
Videos Pricing More Search
BuildAModule Logo Icon BuildAModule Logo Icon
Become a member!
$29
1 month
$156
6 months
10% off
$276
12 months
20% off
All memberships come with the following:
24 / 7 access to the entire 1800+ video library
An innovative video player with a rolling transcript
Extensive Drupal and cross-platform training
A thorough and thoughtful training style
Progress tracking
Take notes on specific video sections
Intuitive multi-user management
How many users?
user
Go solo with a single user, or give multiple team members access through one account and get discounts by bundling multiple users into a single membership.