403 Error

6 replies [Last post]
odechillaz
Offline
Last seen: 5 years 46 weeks ago
Joined: 2011-12-02

I have installed the Acquia Desktop Control panel and when I follow the instructions given in the "Setting up our example folder and creating our first page" video (PHP Programming Basics > Series Introduction and Your First PHP Script), I get a 403 (forbidden)...

when clicking Go To after selecting the newly created site in Settings of the Acquia Dev Desktop Control panel.
Both Apache and MySQL are in the exception list of the Windows firewall.
Any fix or suggestion for this?
Thanks.
:)

Chris Shattuck
Offline
Last seen: 10 weeks 3 days ago
Joined: 2009-08-16
For other folks having this

For other folks having this problem, one of our viewers found that their issue was caused by improper permissions on the MySQL user. They had to go into PHPMyAdmin and add the 'grant' permission to their user. Their user was named 'drupaluser'.

I hope this helps!

Cheers,
Chris

ericaligeski
Offline
Last seen: 7 years 1 week ago
Joined: 2012-09-10
having the same 403 error

I'm having the same 403 error when trying to create an example folder. I updated permissions via PHPMyAdmin and stopped and started the stack a couple times. No luck. Any other ideas?

Thanks!

Erica

Chris Shattuck
Offline
Last seen: 10 weeks 3 days ago
Joined: 2009-08-16
We're now recommending using

We're now recommending using Acquia Dev Desktop or Pantheon instead of Bitnami for following along with the Build Your First Drupal 7 Web Site collection. Below are the videos that walk you through the steps of setting those up:

ericaligeski
Offline
Last seen: 7 years 1 week ago
Joined: 2012-09-10
edit the htaccess file

A possible solution -

You may need to edit your .htaccess file to enable apache to show "directory listings for URLs which map to a directory."

I did this with the help of a friend. We pulled up terminal and navigated to the file directory. For me it was /sites/drupal-7.15.
Used vim to open the .htaccess file.

cd sites/drupal-7.15
vim .htaccess

Where it says:

"Don't show directory listings for URLs which map to a directory."
Options -Indexes

Change the -Indexes to +Indexes

Worked and I can proceed with the tutorial.

Chris Shattuck
Offline
Last seen: 10 weeks 3 days ago
Joined: 2009-08-16
Thank you so much for posting

Thank you so much for posting your solution, Erica!

janmleone
Offline
Last seen: 4 years 47 weeks ago
Joined: 2012-03-19
another solution

I just ran into this issue also. My problem was not moving the .htaccess file into the drupal folder along with other files. I followed this post to show hidden files on my mac. http://osxdaily.com/2009/02/25/show-hidden-files-in-os-x/
I was then able to move the .htaccess folder into the drupal folder.

I hope this helps!

Add to playlist

Add to , or

Add to new playlist:

Add to playlist
This is a member-only feature
But, it's easy to become a member

Add to cart:


Loading...
Contact us

Below are the supported keyboard shortcuts for our video player.

space
Start / stop video
shift
Go to next video
shift
Go to previous video
Increase or decrease player speed by 20%
Skip ahead or go back by 15 seconds
1...9
Jump to a percentage (2 is 20%, for example)
f
Toggle full screen
Videos Pricing More Search
BuildAModule Logo Icon BuildAModule Logo Icon
Become a member!
$29
1 month
$156
6 months
10% off
$276
12 months
20% off
All memberships come with the following:
24 / 7 access to the entire 1800+ video library
An innovative video player with a rolling transcript
Extensive Drupal and cross-platform training
A thorough and thoughtful training style
Progress tracking
Take notes on specific video sections
Intuitive multi-user management
How many users?
user
Go solo with a single user, or give multiple team members access through one account and get discounts by bundling multiple users into a single membership.